iOS app is built with soon outdated SDK

  1. 5 months ago

    I have recently begun to get a warning message from Apple, when I upload an iOS app via Application Loader.
    I include the message below.
    My question is if this is something I can resolve myself or it is something that has to be change in Pubcoder itself?
    I have just update Pubocer to the the newest version 3.4 (982).
    //------------------------------------------------------------------------------
    Dear Developer,

    We identified one or more issues with a recent delivery for your app, "Ballyland Code 2: Give Rotor". Your delivery was successful, but you may wish to correct the following issues in your next delivery:

    SDK Version Issue - This app was built with the iOS 11.4 SDK. Starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later.

    After you’ve corrected the issues, you can use Xcode or Application Loader to upload a new binary to iTunes Connect.

    Best regards,

    The App Store Team

  2. Angelo S

    Feb 9 Administrator

    Hello John, we will fix this on our side. Nothing to worry about at the moment.

  3. Edited 5 months ago by John N

    Thanks, Angelo - will it be a good idea then to wait with launching a new app until you have updated Pubcoder with the iOS 12.1 SDK? We have a new app ready but can wait the few days until March.

  4. Angelo S

    Feb 18 Administrator

    Hello John, no need to wait. That has to to with the submission itself: "Starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK". No problem if you submitted the app previously.

  5. Thanks, Angelo.

 

or Sign Up to reply!