Can't build iOS app with the required iOS 16.1 SDK

  1. 10 months ago

    When I submit an iOS app with Transporter I get the following error warning:

    "SDK version issue. This app was built with the iOS 15.2 SDK. All iOS and iPadOS apps submitted to the App Store must be built with the iOS 16.1 SDK or later, included in Xcode 14.1 or later."

    But, I do have Xcode 14.3 with iOS 16.4 SDK build in.

    Will I have to do something in Pubcoder - or is the problem related to my Xcode?

    Thanks
    John

  2. Angelo S

    3 May 2023 Administrator

    Hello John, we will release a fix as soon as possible

  3. Angelo S

    4 May 2023 Administrator
    Edited 10 months ago by Angelo S

    Here's a beta of PubCoder 4.3.4, which should fix the issue:
    https://www.dropbox.com/s/k66fxm8iuyi6f5n/PubCoder-bin-20230504-4.3.4.1196.zip?dl=0

    Please let us know if this works for you

  4. 9 months ago

    Thanks, Angelo - yes, it works with the beta:)

  5. Angelo S

    8 May 2023 Administrator

    Hello, we've officially released the stable update for PubCoder 4.3.4 which fixes the issue with App Store Connect publishing.

    Please notice that's a different version from the previous one posted here (stable version for Mac is 4.3.4.1197 while beta was 4.3.4.1196).

    You can download the stable version from pubcoder.com/download or directly from PubCoder using Auto-Update

 

or Sign Up to reply!