"Quick Preview Project" is not working on macOS Catalina 10.15.4

  1. 3 years ago

    I have a big problem with Pubcoder on macOS Catalina 10.15.4.
    The "Quick Preview Page" and "Quick Preview Project" does not work.

    My project opens in the "Quick Preview..." - but, interaction is not working at all.
    Like buttons with an action assigned are not responding.

    If I send the project to my iPad with "XPUB -> Wi-fi" it all works.
    Also when I send it as an iOS app via Transporter to TestFlight it works.

    I am using an external Javascript library "TouchSwipe" (http://labs.rampinteractive.co.uk/touchSwipe ) - I have used that for all our iOS apps made with Pubcoder since 2015 and there have never been problems before.
    I have found that if I disable "TouchSwipe" then some of the interaction in "Quick Preview Project" works. But, then everything that is based on "TouchSwipe" is not working of course and the project can't be used.

    I have tried the same .pubcoder file out in Pubcoder versions from the latest 3.8.2 back to 3.6.1 - there are less problems with "Quick Preview Project" in the oldest version - but, still much is not working.

    The problem is only connected to macOS Catalina - it all works on macOS Sierra 10.12.6 and also on El Capitan 10.11.6.

    What can probably cause the problem?

  2. Angelo S

    26 May 2020 Administrator

    Probably that has to do with the TouchSwipe library itself:
    If you create a new project in PubCoder and use the built-in events, does it work? If so, you got the answer.
    Have you tried to send the preview to Safari or Chrome instead of using the internal Quick Preview?

  3. Yes, it has to be because of the TouchSwipe library. Pages not using this library works in "Quick Preview Project on Catalina. With TouchSwipe it does not work neither in Safari or Chrome.

    The strange thing is that on Catalina it all does work when I publish an XPUB to PubReader and also as an iOS app - using the TouchSwipe library.

    But using the same version of Pubcoder (3.9) it all works on both Sierra and El Capitan - "Quick Preview Project".
    So, currently I am developing on Sierra and only use Catalina to publish as iOS app with Xcode 11 - it works but is a bit awkward.

    I have been thinking that it could be a coincidentially collision of variable names - that some variable names in TouchSwipe collides with variable names in other JS files included automatically in Pubcoder.
    But, then it should not fail only on Catalina.

    The reason for using TouchSwipe is that it detects 2- and 3 fingers swipes and double-tap which is essential to our main user group who are blind and visually impaired children.


or Sign Up to reply!