disable page navigation

  1. 6 years ago

    I want to export to html5 and ios app. So, question: How do I disable page navigation? those right and left arrows. I have my own navigation button on a quiz, and I want students to continue only if they select the correct answer. Right now they can easily just go to next page without answering quiz questions.

  2. Angelo S

    26 Oct 2017 Administrator

    Hi, go to Project Inspector in the right panel and disable "touch to open app menu".

  3. Edited 6 years ago by yacine D

    That's already disabled. The menu is not the problem, but it's the page navigation. I also disabled "show page navigation" but it still shows those little arrows.

  4. Okay, I've found a solution. I added a custom CSS to hide the navigation arrows.

    div#SCNavigationRight {
        display: none;}
    div#SCNavigationLeft {
        display: none;}
  5. Paolo A

    27 Oct 2017 Administrator

    Great, I was about to provide same solution, you could use just one style, which encapsulates both:

    div#SCNavigationArrows {

    We are currently looking into project settings to make it work with the "Show Navigation Controls" option.

  6. Edited 6 years ago by yacine D

    Thanks for the code. Changed mine, but somehow it didn't work. So, I had to revert to specifying the right and left.

  7. Ciao,
    Paolo in quale file .css va posizionato il codice?


  8. Angelo S

    24 Nov 2017 Administrator

    @Franco  B Ciao,
    Paolo in quale file .css va posizionato il codice?

    Nelle impostazioni di progetto, Stili CSS

  9. Non ho capito bene. Utilizzo PubCoder 3.01. Ho usato il pulsante Codice - Page "Copertina" e ho provato a inserire un codice e poi l'altro ma dà errore.

  10. I'm having a similar navigation issue. I'm using the Pubreader app on iOS, but it always opens my xpub on the LAST page instead of the first! I have done a bit of rearranging pages with this project, but even at that surely it should respect the page numbering rather than order of creation?

  11. Angelo S

    21 Feb 2018 Administrator

    Hello Lisa,
    by default, PubReader opens the content at the very same page that was seen on the reader. This perfectly makes sense for a book.
    If you want it to open always on the first page (regardless of what page the user was seeing last time it opened the project), you can use the *Opening Page* project option, which was just introduced in the 3.1 release. BTW, to see it working, you have to wait some more days, since the new version of PubReader with support for that functionality (1.3) is currently under review by Apple.


or Sign Up to reply!